Subject: source code availability

From: Dion Johnson <[email-masked]>
Date: Mon, 15 Jun 1998 10:29:33 -0700

One of my friends here showed me your article in login.
Thanks for your kinds words.  Our legal folks have finally
begun to see it all with some humor.  The VP head of Legal
division wants to collaborate on a practical joke on
his staff wherein I will propose another new source
code license that will be totally outrageous... and see how
far it gets before they realize they've been had.

One thing you mentioned in the article stimulated my
memory of old days at IBM.  You said that "having full
source code to any OS was unheard of."  Interestingly,
in the old days, IBM used to provide full source
code to MVS (and other products) to customers.  This
was ca 1966-1970.  They distributed the source as
assembly listings of the OS build, on tape.  So you
could indeed have the source code to a (arguably)
useful OS.  I _think_ that this is how Amdahl and others
got the source code to create their rival versions of
IBM's systems.  

I also recall that around 1970, IBM changed the model, or
maybe realized that software was going to be a product,
not something that came for free with the hardware, and 
they stopped providing source and unbundled the OS from
the hardware.

---

From: Dion Johnson <[email-masked]>
Date: Mon, 15 Jun 1998 16:06:27 -0700

On Tue, Jun 16, 1998 at 08:41:25AM +1000, Warren Toomey wrote:
 > In article by Dion Johnson:
 > I can think of a few 8-)
 > 	+ Too much admin hassle for the $100 fee, just make the
 > 	  ancient UNIX licenses freely available.
 > 	+ Add SysV (any flavour) to the license.
 > 	+ Ask Microsoft if they would release the old versions of Xenix.
 >  
 > Ah, I didn't know that. I assumed that companies didn't do this.
 > On the other hand, the code wasn't useful unless you were leasing
 > a machine from IBM, unless IBM were selling computers by that stage.

IBM was both selling and leasing back then.  The lease prices were
so high that it was about a tossup for customers to choose between
leasing for 3 years or purchase with 5-yr depreciation.  Of course,
the machines usually needed to be upgraded every 2-3 years.   I 
dont recall the exact accounting calculations involved, but I 
expect IBM made it just about equally painful either way.

This new groundswell of sentiment against Microsoft has much in
common with the industry feelings toward IBM back then.... the
difference being that in the 60s-70s, IBM really did provide
a price "umbrella" that kept a lot of other little companies
alive, whereas Microsoft is not so benevolent.