Subject: Re: DRAFT of ancient UNIX license.

From: Dion Johnson <[email-masked]>
Date: Wed, 25 Feb 1998 14:13:05 -0800

On Thu, Feb 26, 1998 at 09:03:34AM +1100, Warren Toomey wrote:
> > > 1. Authorized country?  What's that? Will I who live in Sweden be
> > > able to get the UNIX license?
> > This will be used to fill in a list of the countries which the
> > licensee wishes the license to apply to.  Probably we ought
> > to work up a standard list that everyone agrees on.
> 
> How about ``All countries not excluded in Section 5.2 of this license''?
>  
> 	Warren

I tried to get them to just write the license this way, but they
refused.  So, we simply make up a list of countries and print it
on a page and attach it to the license as licensee-submitted
data.  Or maybe we just write in what you wrote above and see
if it flies.
-Dion

---

From: Dion Johnson <[email-masked]>
Date: Wed, 25 Feb 1998 14:28:08 -0800

On Thu, Feb 26, 1998 at 09:24:05AM +1100, Warren Toomey wrote:
> In article by Dion Johnson:
> > > How about ``All countries not excluded by Section 5.2 of this license''?
> > 
> 8-)
> Sounds good to me. Given I don't actually own a PDP-11 myself, I want
> to see their faces when they see the list of designated CPUs:
> 
> 	KDJ-11 emulator by Bob Supnik
> 	KDJ-11 emulator by John Wilson (aka Ersatz)
> 	User-mode KDJ-11 by Warren Toomey

<snicker>  that will be fun.

> 
> What about SCO including a CD-ROM with each license. Do you think they'd
> be prepared to do this?

Well... hmmm... we are not really staffed in the legal dept and
free stuff programs to do this.  I was hoping you enthusiasts already
have all the code and can share it among yourselves as needed.

E.g. if a new player wants the stuff, they send us $100 and a
filled out license form.  Then we notify you (or notify the PUPS
society) that this person is licensed, and you guys figure out
how to service the new guy.  Would that work?

---

From: Dion Johnson <[email-masked]>
Date: Wed, 25 Feb 1998 14:43:45 -0800

On Thu, Feb 26, 1998 at 09:35:34AM +1100, Warren Toomey wrote:
> Yeah, as long as there's a mechanism for us to guarantee that someone
> actually owns a license. I suppose you guys would like a copy of the CD-ROM,
> too?!
> Thanks,
> 	Warren

I guess if I send you a message that [email-masked] has a license,
that's good enough?  Maybe we need to use PGP to guarantee truth?

Sure, we'd like the CD. ;-)  I will even compensate you for it
somehow...  

By the way, if you want any SCO software for free, just say the
word.  Never mind asking for a 100-user server license, but 
any of the usual stuff is yours for the asking.
-Dion

---

From: Dion Johnson <[email-masked]>
Date: Wed, 25 Feb 1998 14:59:48 -0800

Woops I seem to have misplaced your postal/shipping
address.  Can yoy pls send?  I need a phone number, too.

On Thu, Feb 26, 1998 at 09:56:49AM +1100, Warren Toomey wrote:
> Yes please. And you should send any license identification information,
> such as license numbers etc. According to the license, I have to keep
> copis of this.
> 
> You can pick up my PGP public key from
> 
> 	http://www.auug.org.au/cgi-bin/pgpkey.pl
> 
> which is a key-signing service.
>  
> You already have, Dion.
> 8-) I'm not sure I heard that. I wouldn't mind that free SCO OpenServer
> and UnixWare, at least so I can get Motif up on my FreeBSD box.
> 
> I'll browse your web site & send you a shopping list sometime.
> 
> Many thanks,
> 
> 	Warren

---

From: Dion Johnson <[email-masked]>
Date: Fri, 20 Mar 1998 14:09:32 -0800

>which is a key-signing service.

The service says I need to specify a "normal PGP search string".

Since I have not used PGP before, I dont know what this is.
Can you tell me briefly?

We have about a dozen licenses here, all paid up and signed
off.

Some of the legal folks are still asking questions and raising
objections, but I think the horse has already left the barn. ;-)

Btw, another interesting question:

How does PUPS, yourself, and various others in the ancient
priesthood handle the word "Unix" ?

That is,  I know the original usage was "Unix".
Later, much later, it was trademarked by TOG as UNIX(R).
Some people here are trying to tell me that occurrences
of "Unix" should be replaced by the trademarked version
but I'm not sure that's true.  The older version of
the word relates to the Unix technology as it existed
prior to the trademarked word, so I would try to argue
that "Unix" is perfectly correct usage and does not
refer to that thing which is called UNIX(R).

What's your take on this?

---

From: Warren Toomey <wkt>
Date: Mon, 23 Mar 1998 10:26:45 +1100 (EST)

> Since I have not used PGP before, I dont know what this is.

PGP is a public key system which provides both document encryption and
authentication.

Each person has a private key & a public key. The public key is distributed.

To encrypt a document, you use the receiver's public key. Only the real
receiver can decrypt the document, using their private key.

To sign a document, you encrypt with your private key. Anybody with your
public key can decrypt the document, and this proves that you were the signer.

Encryption and authentication can be combined.

I assume you have PGP version 2.6.3 installed on your system at SCO.
To create your public/private key, do:

	$ pgp -kg 1024

which makes keys of 1024 bits.

You can save your public key in fred.asc by

	$ pgp -kxa xxx fred

where xxx is your login name. Put this file on your web page somewhere.

To add someone else's key (in file jim.asc) to your list of keys:

	$ pgp -ka jim.asc

It is best if you have your email built to use PGP transparently. Otherwise,
here's what to do:

Encrypt a document to remote user xxx:

	$ pgp -o newfile -ea file xxx
 
Sign a document:

	$ pgp -o newfile -sa file

Sign and encrypt:

	$ pgp -o newfile -sea file xxx

Then attach newfile to the e-mail to user xxx.

Decrypting incoming file:

	$ pgp -d infile

Verifying signing of incoming file:

	$ pgp -d infile

> off. Some of the legal folks are still asking questions and raising

Excellent. I guess the country issue would stick in their throats a bit.

> What's your take on this?

Here's my answer below, Dion. Hope this helps!!

	Warren

Here are my reasons why I use the term Unix and not UNIX. You may find the
wording of the following somewhat belligerent: I'm just calling it as I see it.
Therefore, you may wish to tone down the wording for internal consumption.

1) UNIX looks ugly.

	I much prefer Unix to UNIX in terms of appearance.
	This probably explains why UnixWare isn't UNIXWare.

2) Wide existing use of Unix.

	The term Unix is widely used, both in print, in the Usenet
	newsgroups, and in other places (such as freely-available software).
	If the lawyers are going to urge us to use the term UNIX, then we
	say `Why didn't you urge everybody else to do the same?' In particular,
	the 25 Years of Unix book by Peter Salus and John Lions' Commentary
	on V6 talk about the same versions of Unix that we do.

3) We are not violating trademark laws.

	UNIX is a trademark, and so there are set rules on its use.
	Unix is not a trademark, and so we are not violating any laws.

4) No license requirements to prevent use of Unix.

	So far as I can tell, no Western Electric, AT&T or SCO license
	has any clauses about the term Unix, and not to use it.
	I could be wrong here, though.

5) The trademark only came into existence around 1977.

	No 6th Edition files contain the words `UNIX is a trademark of
	Bell Laboratories'. Therefore, there was no trademark specific
	term for the software up to this point.
	
6) Adjective stupidity.

	UNIX still is an adjective, I believe. This results in expression
	stupidity. For example, I can say ``6th Edition Unix was released
	in May 1975.'' However, I have to say ``The 6th Edition of the
	UNIX operating system was released in May 1975.''

	Mind you, this affects SCO's web pages: many of your pages violate
	this adjectival usage:

		UnixWare 7 extends the powerful remote management capabilities
		available in UNIX by providing greater automation and control
		over local and networked servers and simplifies system
               administration  [unixware/new_features/factsheet.html]

What Do I Mean by Unix?
-----------------------

In the most general context, Unix is an operating system that has roughly the
same system calls, user programs, concepts and ethos of 7th Edition UNIX.
Anything which meets POSIX 1003.1 and 1003.2 is a Unix system. This includes
Minix, Linux, FreeBSD, UnixWare and Xenix.

In another context, the research editions of UNIX, and anything derived
from them which is copyright the owner of 7th Edition UNIX (i.e SCO) is
also Unix. Where there is confusion, I use the term `real Unix'. Where
there is no confusion (e.g on the PUPS Web pages), I just say Unix.

Depending on opinion, either 6th Edition or 7th Edition UNIX are the
`one true Unix'. I'd say 7th Edition myself.

Therefore, what the laywers mean by UNIX is roughly what I mean by `real Unix'.
But I don't treat Unix as an adjective.