Subject: Re: Petition for PDP-11 Source Code Licenses

From: Dion <[email-masked]>
Date: Tue, 1 Jul 97 16:34:23 PDT

I think SCO's legal dept has a concern that we do not want
to lose trade secret status or control of certain technologies
and intellectual property that may be in this source code.

Trade secret law provides that we must make certain kinds
of protections for our technology.  We cant just give away
freely because it loses secrecy.  We can provide it under
a suitable license because the license agreement can 
embody the necessary protections.

In other words, we are happy for you guys to have this source
code (possibly with some nominal payment that helps cover our
costs) but we dont want to lose any legal control of the
"secrets".  It may be that we (SCO) still have obligations
inherited from other, ancient contracts with various technology
suppliers about such matters, etc.

Looking at your proposed license terms (strictly an amateur
review; I am not a lawyer :-) I think they seem very fair and
plausible.  I will see if our legal staff can find time to
research this.  I agree that it would certainly be an excellent
PR action for SCO to take, as the flag carrier of the UNIX
heritage.

-Dion
Dion L. Johnson II  - The Santa Cruz Operation, Inc.              [email-masked]
Internet Way of Computing - Java - Technical Tools 
400 Encinal St.  Santa Cruz, CA 95061    FAX: 408-427-5417  Voice: 408-427-7565

	From sco.sco.com!henry.cs.adfa.oz.au!wkt Tue Jul  1 16:11:10 1997
	From: Warren Toomey <[email-masked]>
	Subject: Re: Petition for PDP-11 Source Code Licenses
	To: Dion <[email-masked]>
	Date: Wed, 2 Jul 1997 08:52:26 +1000 (EST)
	Cc: [email-masked], [email-masked], [email-masked], 
	    [email-masked], [email-masked]
	
	In atricle by Dion:
		[ re my petition for PDP-11 UNIX source licenses ]
	> An excellent idea!  Thanks for letting me know.
	> I will certainly be your advocate on this.
	> I just got another request from a guy whom I will
	> copy here so he can participate. :-)
	> 
	> Dion
	
	Thanks for your reply Dion, and send constructive criticism! We'd like to
	know what sort of things SCO would like to see in such a source license.
	
	Cheers,
		Warren

---

From: Warren Toomey <wkt>
Date: Wed, 2 Jul 1997 10:15:36 +1000 (EST)

> PR action for SCO to take, as the flag carrier of the UNIX

Thanks Dion. I can tell you I've had a lot of good feedback about SCO
regarding their support for the Lions' Commentary and their free PDP-11
UNIX binary license. If we can reach an agreement on the source licenses,
then if SCO staged an announcement about them at a USENIX conference,
for example, it would be terrific PR.

I don't know what you guys feel about pricing. $200 would be max, I think,
for individuals to want to pay. $100 would be better :-)

Also, if the license idea gets done, we'd need to come up with a source
code distribution mechanism which is also acceptable. I don't think SCO
would want to bother with it, which is why I mentioned it in the petition.

If a 3rd party was given the distribution task (say me, for example), a
way of proving that someone has purchased the license would be required.
We can come up with the gory details later.

Anyway, less talk from me. I'll let the petition run for a few weeks & then
pass it on to you guys.

Thanks again!

	Warren